Weird problem on Windows XP - skipping ??

I installed ultramixer demo (waiting for activation key) and discovered a strange problem. When I play a song, be it on my hard drive, cd-rom or
audio cd - the song will skip in a few places. More like a drop out, really.

I tried playing with the audio settings, but it did not seem to change things.

I have an HP with a Pentium 4 and m512 meg of memory. I am using an
MAudio Delta 44 card.

This behavior does not happen on any other players.

Chris :confused:

Did you increase the dps buffer siez? you’ll have to restart UltraMixer after changing the audio settings…


Yes…I believe I did increase the dps buffer size. Should it be lower ???


Higher values increases the latency, but reduces sound drops! Please try to increase the (dsp) buffer count to 8 (last slider, buffer size)

Which sound system do you use? Check Menu => preferences => audio => Sound system.

Ok. Will try this. I have tried both directx and asio for my MAudio delta
44 card. Seems not to make any difference.

Well it appears that I have fixed the problem. Here is what I did.

  1. Defragged my c: disk.
  2. Moved a number of underused files including my .wav files
    to my d: disk.
  3. Monitored the performance graph while running Ultramixer and noticed
    that the drop outs seemed to occur when the disk “Q” length was high.
  4. Set the buffers much lower until the “Q” length was nearly flat.
  5. Repeated the process to optimize for lowest “Q” length.

Now after playing about a dozen songs with no drop out, I believe the
problem has been rectified.