Upgrades with Ubuntu


Fantastic software!!! Thank you jumbo for including Linux in the party!

I’m running Ubuntu 9.10 using UM Pro v.2.3.8. I see that v.2.4 is out now. Is this going to appear on my end as and available upgrade to my version? Currently the ‘check for updates’ button says that I’m up to date for my version.

I initially downloaded the new version, but I couldn’t get it to install. I tried uninstalling v.2.3.8 and then installing v.2.4. It wouldn’t run after install. Upon further investigation I found that even after uninstalling v.2.3.8 there was still a folder in my usr/local folder for ultramixer. Could this be the issue? I haven’t been able to find out how to get ‘permission’ to delete the folder to see if it indeed is the problem or not. After a few tries I’ve reinstalled 2.3.8 and am using that. Mostly I’d just like to have the newest version to check out.

I did use the contact form here back on the 13th and am still waiting for a response. Thanks again for the software and your help.


Hello Dan,

I cannot answer the upgrade entitlement issue but with regard to the /usr/local/UltraMixer folder deletion, you will require root access to do it therefore you need to use sudo (in terminal) e.g.
$ sudo rm -RI /usr/local/UltraMixer (or what ever the location of the installation directory is)
Tis will entirely obliterate the installation path and the files within it.
You might also want to do
$ rm -RI ~/.ultramixer (only if your old config is an issue, you could try backing it up and then deleting it)

Can i ask you a question, do you use hardware controllers with your ultramixer on linux, I am trying to find a good solid, ideally feature rich but importantly reliable controller to go with ultramixer on linux.


Hi Jason,

Thanks for the coding to get the files deleted. I did remove all of the old ultramixer and .ultramixer files that I could find. I tried to install 2.4 and I still couldn’t get it to work. It wouldn’t even show up in the applications menu like 2.3.8 does. I was able to get the start up screen to show and even activate my key by going into the ultramixer file and running the shell script icon. After that nothing happened. In the system monitor I couldn’t see where java was even running at all.

Anyway I reinstalled 2.3.8 and now it says that there is an update available and asks if I want to visit the ultramixer site. I click yes and nothing happens. So I went to the site and redownloaded 2.4 and went ahead and installed it over top of 2.3.8. I still show that an update is available, and that I’m running 2.3.8 not 2.4.

I’m not really sure what else to try so I guess I’ll stick with this for now in hopes that one of the developers will pop in with advice.

As far as a hardware controller. I don’t have one at this point. I too would really like to get one that works well with linux so keep me posted.

Thanks again for the coding help.