UM 2.4 Crashes on Launch on Ubuntu 10.04 64-bit


I’ve just tried installing UM 2.4 on my 64-bit Ubuntu 10.04. It installed OK, and when I run /usr/local/UltraMixer/ I get the splash screen loading followed by a dialog box saying

"Your licence is invalid or not applicable to this version of UltraMixer. Now there are two options to proceed:

  1. Try our free demo version.
  2. Activate UltraMixer with a valid licence key."

I haven’t bought the software as I’ve not tried using it yet, so I go for option 1 to run the free demo version. I then get another dialog box saying I need to restart UltraMixer, but when I click OK nothing happens. :frowning:

Here’s what I get in the terminal window - I’ve also included my version of Java, in case that’s relevant.

karine@ubuntu:/usr/local/UltraMixer$ java -version
java version “1.6.0_20”
Java™ SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot™ 64-Bit Server VM (build 16.3-b01, mixed mode)
karine@ubuntu:/usr/local/UltraMixer$ ./
Connecting with db…
connected to db. - Duration: [311 ms]

A fatal error has been detected by the Java Runtime Environment:

SIGSEGV (0xb) at pc=0x00007f5c78a53f53, pid=5150, tid=140035118376720

JRE version: 6.0_20-b02

Java VM: Java HotSpot™ 64-Bit Server VM (16.3-b01 mixed mode linux-amd64 )

Problematic frame:

C [] pthread_join+0x23

An error report file with more information is saved as:


If you would like to submit a bug report, please visit:

Can anyone help me work around this? Thanks.

A quick update…

I realised I still had my Hercules DJ Console MP3 e2 mixer plugged in, and thought maybe that wasn’t helping so I unplugged it and tried re-running UltraMixer.

This time I get a screen asking me which version I want to use, and allowing me to request a licence for the free version.

I’m very happy as I can now go and play with UltraMixer.

Thank you for making a Linux friendly version :slight_smile:

Looks like I’ve run into a different problem as I get a java error message saying “undefined symbol”.

I’ve posted a reply in the thread here - viewtopic.php?f=1&t=1426&start=0&st=0&sk=t&sd=a - I hope it can get resolved quickly.