UM 2.1 Preferences: Audio Channel Assignment Problem


sorry for cross posting (raised this issue already in another post in the “Support” forum), but in retrospect I think that “Bug Reporting” is the more appropriate forum for my issue.

Could anybody please try to reproduce my problem that all devices (deck, monitor) that I assign to the rear channel are audible on [b:5d1e2]both[/b:5d1e2] (rear and front) channels?

I only have one machine with more than 1 channel available (the one where it doesn’t work). If you cannot reproduce it, I would appreciate any suggestions how I can debug what is going wrong on my side. Thanks in advance.

I have previously tried UM 2.0.13. I had set it up for both decks to use the front channels, for both monitors to use the rear channels. Everything worked. Now, with UM 2.1, I don’t get this setup to work any more. I have changed nothing to my setup, neither hardware nor software. But when I go to Preferences and setup the channels accordingly, the monitors (configured to rear channel) play on both the front and the rear channel (using the monitor embedded into the archive).

I have tried to configure the decks for the rear channel for testing, but again: deck playbacks take place on both front and rear channel.

In my Preferences, I am using AutoDetect, which I think results in DirectX. Unfortunately, I didn’t have the time today to go back to UM 2.0.13 to try out again, but again: It definitely worked before I updated. I am using a Terratec 7.1, Java 1.5 on Win XP SP2 (32 bit) on an Athlon 64.

Do you have any idea what is going wrong? Do you have any idea how I could debug the issue? One thing I noticed: With UM 2.0, I was offered all channels (front, rear, center) twice, once entitled “DirectX front/rear/center”, and once something like “QVE for Terratec front/rear/center”. Now, with UM 2.1, there is only the DirectX-setting available in the dop down boxes.

Hello blootplazma,

that sounds to me like you have a new soundsetup in your windows control panel. Please go to Control-Panel/Audio-Settings and make sure you have a 5.1 Speakersetup enabled. I also have a Terratec 5.1 card. I’ll try this tomorrow.

kind regards

Hello blootplazma,

I just checked the DirectX stream splitting stuff and indeed it seems to be broken somehow. Could you please send an email [url=]to the support[/url:ede05]? I’d like to provide you a small patch.

Thank you

Thank you very much for getting back to me.

I just wrote an email to ask for the patch.

I had previously tried to set the windows speaker setup to 5.1 and quadrophonie, both did not work as intended and showed the behavior described above.

The setting “7.1 speaker setup” didn’t work at all (UM couldn’t start any kind of play back) - but that behavior was already known from UM 2.0.x. This is not an important issue for me, as I don’t need more than 2 channels anyway.

The patch seems to solve my problems (and is supposed to find its way into the upcoming 2.1.3 release).