UltraMixer stops in the middle of loading a directory

I’m evaluating UltraMixer Pro on Ubuntu Linux 8.04.

It seems to have most features that I’m looking for. I’d like to use it to DJ for a community radio station, but I’m having a few problems.

When adding a directory, the progress dialog stops at 982/3639 files and just sits there (no excess CPU consumption and UltraMixer still works). I tried moving the file and directory out of the way that it stops on, but it still stops at 982 (just a different file).

Adding a .m3u playlist doesn’t add the music files until another .mp3 is loaded, at which point all the mp3s in the playlist and the new mp3 are added.

I found one example of an Ogg Vorbis file which has some serious digital clipping issues (lots of loud clicks in the output). This file plays fine on all other media players that I have and I tried other Ogg files that were part of the same album and they seem to work fine on UltraMixer. I can send the file to someone if that would help.

Besides these problems, and a few feature requests which I’ll post separately, I really like this program.

Best regards,

Dear Josh,

I am not sure why it stops 982. We don’t have a intended barrier there.
I have some questions:

  1. If you stop the current import are you able to start a new import?
  2. If your restart UltraMixer and start a new import with other files does it also stop at 982?
  3. Might be the cause of this stop a specific file type? Witch file types did you use?

You should send the ogg file to backend (aT) um.com

best regards