Ubuntu 8.04 Ultramixer basic ALSA not working

Hi Guys,
I’ve been having a lot of trouble getting ultramixer to work properly.
By default ultramixer uses OSS and I would like to use ALSA.
Setting the soundcards to Auto-detect or ALSA don’t work, it will revert back to OSS. OSS is not installed, but the /dev/dspX devices exist due to the ALSA OSS compatibility feature in the kernel.

I’ve been reading dozens of posts regarding this issue, but haven’t found a proper solution.

Although using (emulated) OSS does play audio it will lock up every other soundcard in my system (even the ones not selected in ultramixer) making them unavailable for other applications. For a few applications I could bypass this using an extensive .asoundrc and create a ctl,hw,dmix and plug device for every output, but a few applications don’t have the capability to select these virtual devices and need to talk to the hardware directly. Usually this isn’t a problem, because every application has got his own card. But when Ultramixer is started everything is locked and the application can no longer use any card, no matter if ultramixer is using it or not.

In this viewtopic.php?f=3&t=1068&start=0&st=0&sk=t&sd=a post someone suggested to kill pulseaudio, edit .asoundrc and try again. This didn’t work and ultramixer always reverted back to OSS.

Blacklisting the snd-pcm-oss and related modules in both /etc/modprobe.d/blacklist and blacklist-oss doesn’t work.

Using AOSS (Alsa-OSS) gives a lot of errors when starting from terminal and no soundcards show up in the devices list.
Yes, I’ve added the required devices in .asoundrc.

When I select ALSA and restart the program from the terminal it provides no errors.

When I look into the umlog.txt there is no reference to ALSA whatsoever.
OSS is reported :
INFO: Soundcards 0[/dev/dsp]-OSS,1[/dev/dsp2]-OSS,2[/dev/dsp1]-OSS,3[/dev/dsp3]-OSS

The umerr.txt doesn’t show anything about ALSA or OSS.

I tried recompiling the kernel so any reference to OSS was removed.
Although I was able to recompile the kernel, OSS was still there and
a lot of my soundcards were no longer working :confused:

I think ultramixer is a great program, but this alsa thing has gotten me pretty frustrated.

Allright…new info…

I’ve killed the snd-pcm-oss.ko by renaming it.
There are no longer any /dev/dspX devices present.
So now there is no possible way of using any form of OSS.

And guess what…Ultramixer still doesn’t work.
I’ve tried ALSA and Autodetect, both end up reverting back to OSS but this time there are no soundcards to select. Pretty much the same as with AOSS.

umix.log :
INFO: Initializing audio engine with soundsystem 1
Aug 7, 2009 2:45:50 PM model.PlayerNative initAudioEngine
INFO: Init AudioEngine…
Aug 7, 2009 2:45:50 PM com.ultramixer.model.pn.d V
INFO: AudioEngine successfully initialized
Aug 7, 2009 2:45:50 PM com.ultramixer.model.pn.d V
INFO: Soundcards=no sound devices.

This is interesting though… native ALSA doesn’t work and aoss neither.

So let me ask an easy question to you developers…how does ultramixer detect the presence of ALSA and its cards ?
Because somehow it seems ultramixer is unable to find them…

Just a note … its 2nd september now.
My first post was @ 7th august , about a month ago.
During this period over 100 people have seen this post…replies…none
The core members are active on the forums, for they have replied to other posts. No one (guests nor developers) has even taken the small amount of effort of just replying something.

Ok, back to the actual problem. Due to the fact I was unable to properly run ultramixer inside ubuntu 8.04 I had to fallback to using Wine with VirtualDJ for Windows. Yes , the only stable solution was a Windows program. It was slow, fonts were unclear, but at least I could set the soundcards as they should, with ALSA. And it didn’t crash randomly as with some other linux dj programs. Mixxx anyone ?!

Don’t get me wrong , ultramixer is a great program. When you can
work with the way it works in linux (OSS, locking soundcards etc) you’ll get a great piece of software. If you have more advanced plans than just using ultramixer, for example recording with the same machine or using an additional sound program to play jingles or any other sound/movie/flash website (youtube) at the same time…forget it. If you can live with this fact, go ahead and purchase. Owyeah I almost forgot this. I got 2 EKS XP10 midi controller. Do you think they work in the evanluation version which should be full featured (I know they don’t work in the home version which I purchased)… naaah… any post about it…naaah

This doesn’t provide me with a good feeling about the support for ultramixer. It seems that after you have purchased the product and have a technical question about the workings of the software all remains is radiosilence. Yeah for 70 eur ct/min they will help you allright. Pay for program, pay more for support. That’s a real shame… :-\

[b:7b6a5]Cmon guys, get your act together, make us proud of saying we got a proper DJ solution for linux ![/b:7b6a5]

Sidenote : Linux and Audio are perhaps the worst combination ever.
OSS,ALSA,ESS,PulseAudio + all the emulation in kernel or via modules
makes it the equivalent of the Windows DLL hell. Don’t even mention using a soundcard that might be newer then 2002… and PCIexpress won’t work and ASIO… yeah right, tough luck.
I’ve spend weeks of finding out how linux audio works and I was simply schocked by the fact how crappy it was. Now I see why the regular DJ programs use Windows of MAC. Both have got their act regarding to audio together and make it work properly.

If anyone has a comment or perhaps would like to contribute to my post or… you can drop me an e-mail : psychic[at-sign-thingy]xs4all[dot][en][el]
Your help is appreciated.

I have no answer for you, but found same problem, with free edition.

strangely, I have found that demo pro version is able to switch to ALSA sound usage, and after that it works full properly.

But when I revert to free version again, it remains in OSS non-functional status - I try to change to ALSA but after telling me I have to restart program, it falls back to OSS after restarting.

Hey, same problem here.

Ubuntu 9.10 with a Creative Soundblaster Audigy ZS 2 (ALSA).

Tried the Professional version: you can do the switch between ALSA and OSS. It saves your ‘ALSA’ setting, but in my case the MP3’s won’t play ? I keep on clicking on that play button, but nothing happens. The time remains indicator stays the same. No error but nothing happens.

Tried the Free version: here UM does not save your ALSA setting; it keeps going back to OSS.

Anyone got the program running on Ubuntu 9.10 (Karmic Koala) by the way?

This problem is the only reason, why I and many other users, cannot dump the combination of e.g. WinXP/BPM Studio in favour of a Linux-only solution, so please developers look into this issue.

Thanks in advance,
Jurgen L.

Ok, I see. We’ll look into this. Actually, with UltraMixer Pro it works from my point of view.
Did anyone test with the Pro Demo?

I am currently using the pro demo on Ubuntu 9.10. Installed fine and worked on start up. In the preference tab there is the option of ALSA, OSS, or autodetect.

The issue that I’m dealing with is getting the program to split my ASUS mb sound card so that I can cue with the headphones. If anyone has any suggestions for this please let me know…

you will probably need to read through the ALSA documentation to split up the sound card channels in the ALSA configuration file. It’s probably much easier to connect a second sound card.