The licence key you entered is invalid! Please type in the l

Well I downloaded UM 4 , paid for the upgrade from UM3 pro , got my order number and um4key file , and all I get is this message.

The licence key you entered is invalid! Please type in the licence key again.
any help please.


Did you Double Click The licence Key file?

no mate , I just pointed to it on the activation pop up.



I copied the um4 download setup to my laptop , also copies the um4key file , I ran setup , and entered my order number , pointed to the um4key file and it activated straight away.

On my main pc , I uninstalled UM3 and 4 , deleted all registry values , all data , and all folders .
Did a clean install of UM4 , but unlike the laptop , this launched straight in to UM4 , where as the laptop asked me if I wanted to run as demo or activate ,when I tried to activate , no joy , still says invalid keyfile.


well I fired up the laptop today , clicked on UM4 , and guess what it told me the license file was invalid , I went to share-it! and downloaded the um4key file again , and it still wont work.
Some one care to shed some light on this

Hi Daryll,

a few minutes ago i sent you a new one.
The old one was broken.

not received as yet , but I have email from digital river , saying they have charged me euro 229…why is that ???