OpenSUSE: UltraMixer freezes while Initializing AudioEngine

Hi all,

I could install UltraMixer Professional DEMO (containing UltraMixer Free und Basic, version 2.2.1) without problems on my Lenovo ThinkPad T61. I am running Linux OpenSuse 10.3 on this laptop. Unfortunately, the splash screen freezes when the message “Initializing AudioEngine…” is displayed.

I have tried to install UltraMixer as root and lauch it as root or user. Furthermore, I installed it as user and tried to lauch it as root or user, the behavior stays the same in all those cases. I also took care to delete the .ultramixer directory in the root and user home directory before each try, no success. When the splash screen freezes, no messages are displayed in the command line.

I would be happy if somebody could help me with this problem.

Thanks a lot in advance.

P.S.: here are some more system specifications of my laptop:

  • Java™ 2 Runtime Environment, Standard Edition (build 1.5.0_12-b04)
  • Linux kernel linux
  • the sound system is running with ALSA (version 1.0.14-31)

Hello mgraupe,

could you please send us your logfiles from the .ultramixer directory.

best regards

Hi Sl@jaR!

Here are the logs from the .ultramixer directory in my home directory. I installed Ultramixer as a normal user.


Mar 15, 2008 6:27:03 PM com.ultramixer.preferences.UMPreferences
INFO: Different key size…
Mar 15, 2008 6:27:03 PM ultramixer.jF installDefaults
INFO: Loading Images…
Exception in thread “main” java.lang.NoClassDefFoundError: org/jaxen/BaseXPath
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(
at org.jdom.xpath.XPath.newInstance(
at org.jdom.xpath.XPath.selectSingleNode(
at com.bley.javax.swing.SwingFactory_HC.createMessageNew(Unknown Source)
at com.ultramixer.widgets.filearchive.aF.(Unknown Source)
at com.ultramixer.widgets.filearchive.A.d(Unknown Source)
at com.ultramixer.widgets.filearchive.A.(Unknown Source)
at com.ultramixer.widgets.filearchive.A.b(Unknown Source)
at com.ultramixer.widgets.filearchive.b.(Unknown Source)
at com.ultramixer.widgets.filearchive.b.a(Unknown Source)
at com.ultramixer.util.h.f(Unknown Source)
at com.ultramixer.main.view.aD.b(Unknown Source)
at com.ultramixer.main.view.Start.main(Unknown Source)


Mar 15, 2008 6:27:04 PM ultramixer.dC b
INFO: --------System Data----------
Mar 15, 2008 6:27:04 PM ultramixer.dC b
INFO: userOS=Linux
uml=UltraMixer Professional DEMO
Mar 15, 2008 6:27:04 PM ultramixer.dC b
INFO: -----------------------------
Mar 15, 2008 6:27:04 PM com.bley.internal.APILogger info
INFO: I18n-File not exists: file:/home/mgraupe/tmp/UltraMixer/lib/res.jar!/res/i18n/i18n_eng.xml -> Try to use backup-file: file:/home/mgraupe/tmp/UltraMixer/lib/res.jar!/res/i18n/i18n.xml
Mar 15, 2008 6:27:04 PM com.bley.internal.APILogger info
INFO: Load i18n-file=file:/home/mgraupe/tmp/UltraMixer/lib/res.jar!/res/i18n/i18n.xml
Mar 15, 2008 6:27:05 PM com.bley.internal.APILogger info
INFO: PropertiesFile: /home/mgraupe/.ultramixer/data/guiproperties.xml
Mar 15, 2008 6:27:05 PM com.bley.internal.APILogger info
INFO: CreateBlankProperties: doc=[Document: No DOCTYPE declaration, Root is [Element: ]]
Mar 15, 2008 6:27:05 PM com.bley.internal.APILogger info
INFO: saveProperties: /home/mgraupe/.ultramixer/data/guiproperties.xml
Mar 15, 2008 6:27:06 PM com.ultramixer.util.h b
INFO: Classpath=.:lib/UltraMixer.jar:lib/res.jar:lib/skinlf.jar:lib/jdic.jar:lib/jdic_fileutil.jar:lib/hsqldb.jar:lib/TableLayout.jar:lib/JFreedbClient.jar:lib/tbley.jar:lib/swing-worker.jar:lib/entagged-audioformats.jar:lib/umupdate.jar:lib/saxpath.jar:lib/jaxen-jdom.jar:lib/jaxen.jar:lib/jdom.jar:lib/IClock.jar:lib/freeJSX1.0.7.5.jar:lib/l2fprod-common-directorychooser.jar:lib/l2fprod-common-fontchooser.jar:lib/swingx.jar:lib/xstream.jar:lib/swingx-ws.jar:lib/jdic_stub.jar:lib/jadaptivemenu.jar

Let me know if you need more.


Hi mgraupe,

thanks for the information. I’ll take a look at it when we get back from the fair trade (Musikmesse) in Frankfurtr.

best regards