[Linux] Bad sound in ultra mixer

Hello there.
I just downloaded the linux version of Ultra Mixer and have successfully installed on my (Ubuntu) laptop.
However the sound is terrible, it lags and sounds like my speakers are cracking.
I don’t have this problem with any other applications.

I think the problem might be that UltraMixer is using OSS sound system, normally I use ALSA.

What can I do?


Hi gardar,

what’s the average performance of your laptop system. Which other applications did you compare? Which ubuntu version have you installed? Please give us more information about your system, sound cards and so on. Have you already tried to increase the buffer sizes in UltraMixer … Preferences/Audio-Setup.


My laptop is a brandnew Dell XPS M1210… with 1.83ghz intel core 2 duo. I have Ubuntu 6.10
All other applications work… amaroK, Mplayer, and also some sound editing software, LMMS.
Sound Card: 00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

I have already tried increasing the buffer and playing with the settings but nothing I tried did change anything.

Hi gardar,

are you sure you used 2.0.11?


UltraMixer: v2.0.11.
AudioEngine: PN
Java: 1.5.0_08-b03

Any idea what I can do to fix the sound?

I really would like ultramixer to work, before my trial runs out… :confused:

Hey gardar,

have you already tried to increase the DSP buffer count and dsp buffer sizes in the preferences/audio setup dialog?


Yes, I have tried to increase all buffers to max… but it didn’t change anything…

Anything else I can do? :confused:

Hi gardar,

does ultramixer bring some printouts on a terminal?
Please start ./UltraMixer.sh from a terminal to see them.

Actually, I haven’t heard of problems like this so far. Could your please try to run it as root. If this doesn’t help, please try to increase the nice level (use “renice”) of all UltraMixer threads.


Allright, so I started ./UltraMixer.sh as root
It didn’t give me any errors or messages in terminal and in the application until I was closing ultramixer, then there popped up a message that ultra mixer had one or more errors and I was asked if I wanted to submit them. I submitted them but wasn’t able to view what the bug was about… Maby you can check it out, I submitted it just about two minutes ago (about 00:55 at my place).

I changed the priority to nice -20 which is max, but that didn’t fix the sound at all.

Do you maby want me to record some of the sound, so you can hear the lag and cracking?

Hi gardar,

in general I believe you if you say you are hearing a crackling sound :wink: In this case it might be good to hear it, probably that leads us to a solution.


I am experiencing the same problem; I went to the control panel and switched everything over to OSS; my regular mp3 player software (XMMS) sounds fine, but UltraMixer2 is not decoding the files properly. FWIW, I am using an older system, but I’m not having problems with any other audio apps and OSS.


Hi grmbrand,

wich linux do you use? I assume it’s Ubuntu as well. Officially, we do only support SuSE Linux. Generally, it’s of course possible to run UltraMixer on any Linux system. I am quite sure there must be something like a different OSS/ALSA library on Ubuntu that might cause this behaviour. I’ll try to install a clean Ubuntu system virtually.



Same with my installation: XUbuntu 7.04 - FF - on laptop toshiba satellite a110-160.
Lags and cracks at the sound output.
It’s the only sound app behaving this way; ALSA is what is configured by default (I guess).
Any hints to overcome this problem?
Many thanks.


Hello Mario,

well we couldn’t find a problem with Ubuntu until now. Did you already try to increase the audio latency by increasing the buffer count and buffer size in the audio preferences setup dialog?


I notice you use an intel HDA type soundchip… I have the same kind, and I had the same problem. The following seems to help:

execute the following in a terminal:

sudo pico /etc/modprobe.d/alsa-base
The above is for ubuntu, for other distributions you might have to execute it as root without the sudo…

add (in the end for example) the following + save with ctrl+w:

[code:e3bf5]options snd-hda-intel position_fix=1[/code:e3bf5]

this got rid of the crackling on the hda output. I also adjusted some sliders in the audio preferences of ultramixer to increase buffers, to prevent sound from “pausing” when I change windows on my desktop (that was a problem allthough I have 2 gb of ram, a shame)…

I still have some of the crackling on the soundblaster mp3+ usb soundcard I use (for monitoring), but that’s less of a problem for me since I only use it for monitoring, so I am the only one that hears the crackles :slight_smile:

I do hope ultramixer will in the (somewhat) near future support alsa, as I usually have less problems with that then when using oss emulation…

Hello TRiSS,

thank you for your interesting observations :slight_smile:

Sure ALSA suport would be nice. It is running somewhat in our test environment. I hope we can release it in 2008. Press your thumbs the ALSA-api doesn’t change again :wink:


I have the same problem (scratchy sound) on a fujitsu-siemens laptop :frowning: . The OS is linux Mint -daryna (ubuntu 7.04)
Intel pentium 2 duo, 2GB Ram,
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03).
I have set all the settings (buffers, etc,) to maximum.
I use Ultramixer 2.2 Free edition.


I have reported this problem too in viewtopic.php?f=3&t=805&start=0&st=0&sk=t&sd=a .

I have ubuntu 8.04 and Intel Corporation 82801G (ICH7 Family) on IBM Z61p and OSS.

Setting off all buffers to max doesn`t help.

Thanks for any ideas