[HOW TO] Install on Linux Ubuntu

French / English language :

  1. S’assurer de l’installation de Java (version Sun):
  2. To ensure itself of the installation of Java (Sun version):

[code:baadf]$ java -version
java version “1.5.0_05”
Java™ 2 Runtime Environment, Standard Edition (build 1.5.0_05-b05)
Java HotSpot™ Client VM (build 1.5.0_05-b05, mixed mode, sharing)
[/code:baadf]
Fr: Je l’ai personnellement installé avec la méthode du Wiki Ubuntu.fr. Il ne faut pas oublier de mettre à jour la configuration pour que ce soit toujours la machine SUN qui soit prise en compte:

Uk:I personally installed it with the method of Wiki Ubuntu.fr. One should not forget to update the configuration so that it is always the machine SUN which is taken into account:

FR: Pour cela, dans un terminal, faites :
UK: Type this code to java conf

[code:baadf]
sudo update-alternatives --config java
[/code:baadf]

FR: et choisissez le numéro de la ligne correspondant à la version la plus haute de Java.
UK: And choose the line number of the last version of Java.

[code:baadf]/usr/lib/j2re1.5-sun/bin/java. [/code:baadf]

FR : Validez : Java est maintenant entièrement fonctionnel.
UK : Enter the number of line. Press enter and now you use JAVA 1.5x

  1. FR : Inscription sur le site d’UltraMixer pour avoir la dernière version Beta. Il faut télécharger la version Linux avec Java (malgré tous les avertissement que peut donner un navigateur sur l’absence de version Java). Cette version s’appelle (en tout cas chez moi). La mettre quelque part dans le dossier utilisateur (~). Chez moi: ~/software

  2. UK : Inscription on the site of UltraMixer to have the last version Beta. It is necessary to download the Linux version with Java (despite everything the warning which a navigator can give on the absence of Java version). This version is called (in any case at home). To put some share in the file user (~). At home: ~/software

FR : Téléchargé la dernière version :
UK : Download the last version:

[b:baadf]UltraMixer-2.0.xbeta-linux-withjava.jar[/b:baadf]

  1. FR : Installer le programme
  2. UK: Setup

FR : (Je mets mes programmes dans un dossier software de mon dossier utilisateur. Adapter en conséquence.)

UK : (I put my programs in a folder named ‘software’ of my file user. To adapt consequently.)

[code:baadf]$ cd ~/software/
$ java -jar UltraMixer-2.0.3beta-linux-withjava.jar[/code:baadf]

FR : J’ai la flemme de faire des copies d’écran. Pour un habitué des installations Windows, rien de très compliqué:

UK : Now setup runing and choose option installation

a. Language: ENG (anglais)
b. “Next”

ETC…

  1. FR : Lancer le programme
  2. UK : Run the programme

[code:baadf]$ ~/software/UltraMixer/UltraMixer.sh[/code:baadf]

FR : Le son ne sort pas pour une raison inconu nous devons cliquer sur le bouton mute 1 ou 2 fois. Et voila amusez vous bien !
PS: Tester avec ESD et non Alsa

FR: The sound does not leave for no reason we must click on the button Mute 1 or 2 times. Enjoy ll! PS: Tested with ESD and not Alsa sound.

thanx a lot :smiley: , but can pleaze s.o. translate, i can t SPEAK and UNDERSTAND french :smiling_imp:

Hi 2fel,

I don’t speek french either :slight_smile: But basically the problem on Ubuntu is the java installation. You will need the Sun Java Runtime Environment (JRE). As far as I know Ubuntu uses a GPL’ed Java implementation that doesn’t work with UltraMixer. Try typing:

[code:3c346]
$ java -version
[/code:3c346]

If there is something like Sun and 1.5.0 or higher than it should work out of the box. Otherwise you will need to install the Sun JRE.

Happy Mixing!
[email protected]

Yes [email protected] !

Menbers does download and use the Sun Java Runtime Environment
Here download the last version of Java [url:5a2a1]http://www.java.com/en/download/manual.jsp[/url:5a2a1]

Now they are HOW TO Install on UBUNTU in English and French language.

Super tutorial, merci :smiley:

Je ne voyais vraiment pas comment installer, et là… ce tuto ! Super !

Par contre ça doit être Java qui fait ça, mais ça rame un peu, et j’ai déjà au bout de 10 minutes mon premier bug : la musique en cours qui joue en boucle, mais impossible de voir quelque chose, la fenêtre est toute grise :confused: Et quand je minimise, l’accès au bureau est normal, mais une fois maximisé, UltraMixer est tout gris, impossible de l’arrêter…

Hallo,
Configuring the last Java version (1.6, in my case) worked for me.
To whom it may interest I’m using (X)Ubuntu 7.04 on a laptop Toshiba Satellite A110-160 and I need to get an USB/firewire audio interface because the defaul sound card lacks flexibility - suchs!
And I must leave now to test UM - 20 days to go.
Bye, bye now.
Merci, Danke and Thanks craquos. :smiley:

À bientôt.
Mário

Hi marsanpin,

we are always about to make UltraMixer forward compatible, so from our side there is no reason to stick with java 1.5 :slight_smile: Actually, UltraMixer will support 1.5 as long as there is no other JRE available for MacOSX.

regards
[email protected]

Hey all,

Since I recently did yome tests on Ubutunty 7.04 I found some pretty easy steps to install the latest SUN java:

1.sudo apt-get install sun-java6-jdk
2. Make the new Java your default java : sudo update-alternatives --config java

regards
[email protected]

I have 8.04 Hardy Heron with the following Java installation:

$ java -version
java version “1.6.0_06”
Java™ SE Runtime Environment (build 1.6.0_06-b02)
Java HotSpot™ Client VM (build 10.0-b22, mixed mode, sharing)

Checking the default version provides this:

$ sudo update-alternatives --config java
[sudo] password for USR:

There are 2 alternatives which provide `java’.

Selection Alternative

      1    /usr/bin/gij-4.2

*+ 2 /usr/lib/jvm/java-6-sun/jre/bin/java

Press enter to keep the default[*], or type selection number: 2
Using ‘/usr/lib/jvm/java-6-sun/jre/bin/java’ to provide ‘java’.

I have registered the free version, and after I select the Free option on startup, the splash screen runs a while and then vanishes, leaving no trace of the program running. I am new to Ubuntu, so maybe I am missing something.

Can someone help?

I would also like to know the answer to this one… I can’t even get as far as the splash screen.–Virtualdj is one of the programs keeping windblows on my doulboot set up.

Hello dts-evolve,

what CPU type do you have? 32 or 64 bit?

regards
[email protected]

Has any one managed to get UltraMixer working under intrepid or are we waiting for a working alsa version?

I have UltraMixer working under Intrepid.

My only problem now is trying to get headphones (monitor) running through a different channel of my 8.1 soundcard. I had this working in Mixx, by selecting:

Main Output: ALSA, Channel 1:2 (front, normal green coloured jack)
Headphone: ALSA, Channel 7:8 (side, blue coloured jack i think)

Unfortunately UltraMixer doesn’t support ALSA at the moment and this is keeping me from buying a copy.

For those who had trouble with their java version in Ubuntu i just went into Synaptic and uninstalled everything java and had “gjc” in the name. Then installed everything with “sun” and java in the name.

If someone could say exactly which packages need removing/installing that would be good, because I just guessed, but now it works at least.

So now under Menu > Prefs > Audio, I only see OSS device /dev/dsp. Does anyone know if its possible, or how to, emulate an oss device of /dev/dsp1 to ALSA channel 7:8??

[quote=“isolated”:0078c]
Unfortunately UltraMixer doesn’t support ALSA at the moment and this is keeping me from buying a copy.
[/quote:0078c]
This is not correct. UltraMixer supports ALSA since 2.3.6

see: ultramixer.com/ultramixer-versions.html

There is a easy way to install on ubuntu linux ive installed it on ubuntu 12.04 mint 12 ubuntu netbook remix

  1. goto package manage/ubuntu software centre and download java 6 runtime

  2. Download ultramixer.jar from the website

  3. Once downloaded right click the file click permissions and select allow excuiteing files as program

  4. Right click and select open with java 6 runtime this should start the installer
    5)Once its installed goto the default directory and double click ultramixer.sh file to start the program

  5. Enjoy :slight_smile:

ok i seem to be having issues with the install, everything i do it wont install, when i navigate to the ultramixer.jar i right click and open with java, an icon appears in my panel for about 10 seconds then dissapears and when i run in the terminal i get this

[code:6e942]Exception in thread “main” java.lang.NoClassDefFoundError: org/jdesktop/swingx/JXPanel
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
at com.ultramixer.main.view.Start.main(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.jdesktop.swingx.JXPanel
at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
… 13 more
[/code:6e942] this is realling starting to frustrate me, any help would be awesome