Hanging splash screen during "initializing AudioEngine"

Hello. Trying to run UltraMixer v2.2.1 on my Windows XP system. I believe it was properly installed on my computer but everytime I run the UltraMixer.exe, I get an error message that reads:

[b:14451]DATABASE UPDATE [/b:14451]
[i:14451]“Your FileArchive contains an old structure, and has to be updated. Do you want to complete the update now? Attention: After updating your filearchive older versions of UltraMixer doesn’t work anymore! We recomment you to export your current filearchive before updating it. If you object the update, UltraMixer will be closed.”[/i:14451]

Any ideas on how to troubleshoot this? Was it because I had a previous trial version loaded on my computer? And what is a filearchive?

Also, it seems that someone else encountered this problem a while back. ultramixer.com/index.php?c=Z … Z0PTUxNg==

However, I run none of those programs on my system that they used and am not nearly as familiar with the lingo to fully understand and comprehend it. Thank you in advance.


Dear tplante,

just download version from the download-part of this site and install it. - Older versions are not longer supported!