display issues Ubuntu 10.04

I’ve been successfully running UM 2.3.8 on Ubuntu 10.04 since April with no real issues.

This week I discovered that 2.4.3 had been released. Awesome. I installed it and much to my surprise it worked without issues. I was prompted to update my archive and I did. Still no real issues.

Yesterday I upgraded my Ubuntu to 10.10. Problems. When I open 2.4.3, all of the text is cut off in ‘odd’ places. Only ‘half’ of words are visible. The program still runs, but it is very difficult to use without being able to see all that is going on. All the buttons work, but all the menus are ‘half text’ as are the song titles and times in the players.

I tried to reinstall 2.3.8 but it won’t run. I get the prompt to update my archive and then it locks up. Also, this prompt has it’s text shortened as well.

Is this an issue with Ubuntu? Or my install?

I have also been wondering where UM stores all of its data. Even after deleting the /usr/local/UltraMixer folder some bits of UM remain somewhere. I know this because when I reinstall the program all of my settings are restored. This should not happen on a fresh install.

I thought maybe if I ‘cleaned’ UM completely from my machine I could start fresh and it should work again.

I remember having issues with UM install until I did I new install of Ubuntu 10.04 back in April. After redoing the operating system from scratch, there were no problems. This is why I’m asking how to get rid of all of UltraMixer without having to reinstall the operating system.

Let me know what other information I might need to provide to help me get this fixed.

UltraMixer rocks!

Never fails. :slight_smile:

I discovered my problem within my java configuration. Even though I had sun java installed it was not set to default.

Problem fixed. UltraMixer rocks!

I use UM since a few days… and i have exactly the same problem with the 2.4.3 version and ubuntu 10.10…

Could you explain more precisely, what have you done to use java properly and hve you managed to read all of the text.

Thanks for your answer. :laughing:


UltraMixer requires Sun Java to function as opposed to OpenJDK. I’m assuming that during the upgrade my configuration was changed.

This page lays it out fairly clearly how to find out what java you are using and how to select which one you want to use. My guess is that it has been changed to OpenJDK. Once I changed my selection, I might have rebooted - after that it worked fine.


I hope that helps, if you haven’t figured it out already.