Cannot launch Java application on ultramixer startup

Mac OS X 10.5.2, Intel iMac, 3GB RAM, Java version 1.5.0_13

I downloaded and installed the 2.2.1 demo software yesterday. It ran more or less fine. I could navigate to my iTunes directory and load all the songs in a directory and play them (with the aac/m4a plugin). Today I got an activation key for the “free” version and activated the key. After doing that, when I try to run Ultramixer I get the following error:

[b:211c5]Cannot launch Java application
Uncaught exception in main method: java.lang.NullPointerException[/b:211c5]

I’ve uninstalled and re-installed the software and reactivated it with the free key. I still get the error, which prevents Ultramixer from running. I have java version 1.5.0_13:

~ $ java -version
java version “1.5.0_13”
Java™ 2 Runtime Environment, Standard Edition (build 1.5.0_13-b05-237)
Java HotSpot™ Client VM (build 1.5.0_13-119, mixed mode, sharing)

The Java preferences pane (/Applications/Utilities/Java/Java Preferences) is configured to find and use J2SE 5.0 (1.5) first (1.4.2 is also installed).

Here’s the contents of the umerr.txt file:

[3]$ cat umerr.txt
Mar 15, 2008 12:21:16 PM com.ultramixer.preferences.UMPreferences
INFO: Different key size…
Mar 15, 2008 12:21:16 PM ultramixer.jF installDefaults
INFO: Loading Images…
[LaunchRunner Error] com.ultramixer.main.view.Start.main(String[]) threw an exception:
at ultramixer.lW.b(Unknown Source)
at ultramixer.bT.c(Unknown Source)
at ultramixer.eS.f(Unknown Source)
at com.ultramixer.main.view.aD.g(Unknown Source)
at com.ultramixer.main.view.aD.b(Unknown Source)
at com.ultramixer.main.view.Start.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at apple.launcher.LaunchRunner.callMain(
at apple.launcher.JavaApplicationLauncher.launch(

Please download 2.2.1 again.


I downloaded 2.2.1 again and installed it after uninstalling the previous install. This time it started up and appeared to recognize my free registration key. However, when I loaded a directory from my iTunes library into the left-side playlist, it appeared to play a song, but produced no audio output. So I loaded another directory from my iTunes library into the right-side playlist. When I attempted to play a song from that playlist, the application crashed. Now when I attempt to start or restart it, it simply crashes.

The error that is reported is:

[b:c4ea7]The application UltraMixer quit unexpectedly. The problem may have been caused by the libfmodex.dylib plug-in.[/b:c4ea7]

Clicking on “Relaunch” restarts the application, whereupon it crashes. The result is an endless series of restart/crash, restart/crash. Or start/crash, start/crash, …

Dear um_user,

please send an email [url=]to the upport[/url:55154].
You will receive an email with instructions that call for log files.

Thank you

Has this been resolved?
I have the same problem with a macbook 2 GHz with 2Gb of RAM OSX 10.5.2

It worked the first time I installed it, but comes up with the same error mentioned

Cannot launch Java application
Uncaught exception in main method: java.lang.NullPointerException


Dear daiprice,

please send the logfiles [url=]to the support[/url:f47f9].

best regards