"Uncaught exception in main method"

My knowledge of computer language is extremely minimal. I have a MacBook Pro with OS 10.4.9 and downloaded the free version of ultramixer. When I installed it, all that running the program gets is

“Cannot launch Java application
Uncaught exception in main method
once you get to “initializing AudioEngine”

I don’t have a damn clue what this means. I downloaded Java Update 5, which was the most advanced update I could find, but it hasn’t made a difference. On the download page it says that my Java version is ?. That doesn’t make any sense.

What am I doing wrong? Have I got the wrong Java version still or is the problem something else?

Hi bear,

thank you for your interest in UltraMixer.
Fortunately, you don’t have to have knowledge in programming languages at all :slight_smile:
Well, we had never problems with the installation routine on MacOSX. The only prerequisite is Java 5 (or 1.5) from apple. After you ran the java installer from apple.com the UltraMixer startup scripts will find the appropriate java version automatically.
The detection on the website only works properly when java support is enabled for you browser. In case of safari or firefox you might need to enable this support first to allow the detection.

Maybe everything is installed correctly now on your system and you just need to reboot the entire system.


Same error using MAC OS 10.4.9 and Java 1.5.0_07-87. Ultramixer 2.0.13 free version

I’ve tried to install java from apple / java and installer told me that a newer version was already installed.

Rebooted and everything the same.


do you have an PPC or Intel Mac? Btw. any 1.5 java version should be sufficient.


Sorry, I didn’t tell.

It’s an Intel Mac…

No ideas?

I’m really interested in trying this software. I’m about to buy a Behringer BCD 3000 and maybe I use UM with it. Easier than Traktor…

But first I want to have an overview…

Could you run the UltraMixer-installer without problems?