UltraMixer

Hi…
I install UltraMixer-2.0.4beta-linux && jre-1_5_0_06-linux
When i start UltraMixer … it apear a picture (prompt picture) … and stay like that … nothing happen …
This is in console …

Mar 3, 2006 4:33:52 AM com.ultramixer.preferences.c
INFO: Different key size…
Mar 3, 2006 4:33:54 AM model.PlayerNative
WARNING: Couldn’t load native library! Switch off backend (MODEL_OFF=true)
java.lang.UnsatisfiedLinkError: /usr/local/UltraMixer/libPlayerNative.so: libstdc++.so.6: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at model.PlayerNative.(Unknown Source)
at com.ultramixer.model.pn.PlayerFmod4.h(Unknown Source)
at com.ultramixer.model.a.b(Unknown Source)
at com.ultramixer.main.view.StartUltramixer.b(Unknown Source)
at com.ultramixer.main.view.StartUltramixer.main(Unknown Source)
Exception in thread “main” java.lang.UnsatisfiedLinkError: Command
at model.PlayerNative.Command(Native Method)
at com.ultramixer.model.pn.PlayerFmod4.h(Unknown Source)
at com.ultramixer.model.a.b(Unknown Source)
at com.ultramixer.main.view.StartUltramixer.b(Unknown Source)
at com.ultramixer.main.view.StartUltramixer.main(Unknown Source)

I hope to tell me … what to do !

THK’S !

Hi xmmd,

you’ll probably need a newer libstdc++. Unfortunately, this version of UltraMixer is linked against version libstdc++.so.6. I assume you are using Ubuntu that’s actually not up to date. Well, we will fix this issue for the next release.

regards
Sl@jaR

Hi ,

Slackware 10.2 , no Ubuntu …
I have to wait the next release ??
I newbie in linux … :confused:
What can i do ?
If I upgrade my libstdc++ , it will working ??

Thk’s !
Bogdan ,

Hi Bogdan,

you can wait for the next release but it will work with libstdc++.so.6. Actually, an upgrade of this library may break your entire system!

regrads
Sl@jaR

After 2.0.4 … same 2.0.5 is not working on me !
This time … another error …
Take a look pls …

[code:f96a7]
./UltraMixer.sh

An unexpected error has been detected by HotSpot Virtual Machine:

SIGSEGV (0xb) at pc=0x40039b60, pid=25969, tid=16384

Java VM: Java HotSpot™ Client VM (1.5.0_06-b05 mixed mode)

Problematic frame:

C [libpthread.so.0+0x9b60]

An error report file with more information is saved as hs_err_pid25969.log

If you would like to submit a bug report, please visit:

http://java.sun.com/webapps/bugreport/crash.jsp

Aborted
[/code:f96a7]

[b:f96a7]WHAT to do[/b:f96a7] ? :cry:

Hi xmmd,

please send an email to [contact]. If you like I could need your personal support to find this issue on your Linux distribution :wink:

regards
Sl@jaR

I get the same error as xmmd

Running: Debian 2.4 and UltraMixer 2.0.5

Hi Caen,

the issue has been fixed for 2.0.6.

regards
Sl@jaR

Hi,
I’m using the new Beta 2.05 and my lib is libstdc++.so.6, so I have the same situaction, What I need do to use UltaMixer ?
My SO is Fedora Core 5.

Regard’s

Raphael

Hi Raphael,

yes it seems to be a problem on newly updated distributions. I assume it affects every distribution. We actually, have a solution for this issue and it will be available in 2.0.6.

regards
Sl@jaR